1033. To Fill or Not to Fill

题目

1033 To Fill or Not to Fill(25 分)
With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax(≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; Davg(≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: P_i, the unit gas price, and D_i(≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

1
2
3
4
5
6
7
8
9
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

1
749.17

Sample Input 2:

1
2
3
50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

1
The maximum travel distance = 1200.00

想法

DP或者贪心吧

找最便宜的GS,然后走最远的路,直到将整个路线覆盖完
实现起来,好像并不是那么容易

不就是遍历嘛,不会太久的hhh

答案

还好AC了,很担心超时

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
//
// Created by Zhao Xiaodong on 2018/8/27.
//
#include <iostream>
#include <algorithm>
#include <climits>
#include <vector>
using namespace std;
struct Info {
int distance;
double price;
};
int main() {
int CMAX, D, Davg, N;
cin >> CMAX >> D >> Davg >> N;
vector<Info> gs(N);
for (int i = 0; i < N; i++) {
cin >> gs[i].price >> gs[i].distance;
}
auto cmp = [](Info &a, Info &b) {
return a.price < b.price;
};
sort(gs.begin(), gs.end(), cmp);
vector<bool> road(D, false);
double cost = 0;
for (int i = 0; i < gs.size(); i++) {
if (find(road.begin(), road.end(), false) == road.end())
break;
int pos = gs[i].distance;
int cnt = 0;
for (int j = pos; j < pos + Davg * CMAX && j < road.size(); j++) {
if (!road[j]) {
road[j] = true;
cnt++;
}
}
cost += cnt * gs[i].price / Davg;
}
if (find(road.begin(), road.end(), false) == road.end()) {
printf("%.2f", cost);
} else {
double maxDist = (double) distance(road.begin(), find(road.begin(), road.end(), false));
printf("The maximum travel distance = %.2f", maxDist);
}
return 0;
}